How to enter BIOS settings on HP laptop?

I was given a used, HP Laptop, model 15-f271 wm. I want to install Linux Mint but I have not been able to enter the BIOS setup to disable Secure Boot and set for Legacy BIOS. I am assuming that I need to change these settings. Most of my operational computes are over 10 years old and did not need these change. I did this for my best computer which was made in 2014 and duel boots with Mint and Windows 10. Windows is currently used rarely and I know almost nothing about how Windows works past Windows XP.

I have tried to find a way to enter the BIOS with an Internet search, but nothing I found worked. I tried to reset Windows thinking I could get rid of any security settings made by the previous owner. When I get to entering my user name or my network password, the keyboard just seems not to work at all. Any help with installing Mint on this machine, or just getting into the BIOS, would be greatly appreciated.

HP has historically used F10 to access its CMOS/BIOS. Currently HP Support shows the following:

If that doesn’t work as described, what if you repeatedly tap F10 vs Esc?

It almost sounds as if the keyboard isn’t recognized. Are you using a standard wired USB keyboard or a wireless model? Just throwing that out there. :blush:

As a last resort try powering off and then on and then try swiping all the F-keys. You might try the control, spacebar and alt keys as well. Maybe you’ll get lucky.

Remember… the person closest to the keyboard when it works is the one who gets the credit for fixing it… :crazy_face::nerd_face:

Added later… or try this site:

No luck. I think because I tried to reset Windows, the computer is booting to what looks like an installation of Windows. It asks what keyboard layout and asks if I want to connect to the network. I pick my router with the mouse and it asks for the password. I type but it does not work. I am using the laptop, builtin keyboard. I tried an onscreen keyboard and the Cortana thing. Cortana responds to the setup answers I give to its questions but does not enter text into the password box. Taping the F10 key repeatedly does not work for me.

I tried all of the function keys with no luck. If I install a new hard drive, do you think I could get into BIOS? What about removing the existing hard drive and trying to get in? I don’t know right how hard it would be to remove the drive. I have only done that one or two time in the past. I have a laptop with a bad SSD that has no problem booting to a Linux live USB drive.

That’s probably worth trying. It makes sense that the BIOS logic would do something different if the path to the OS was broken. Maybe it’ll default to the BIOS screen.

1 Like

I completely agree w/ H200h in that the person between the keyboard & workstation gets the credit regardless. :blush:

I know the “Try this. Try that” gets frustrating after a while. I despise it especially when it seems you’re going in circles. :face_with_raised_eyebrow:

What you describe sounds like Windows performing an initial configuration as if it was a brand new installation of Windows or a brand new laptop fresh out of the box that had been powered on for the 1st time. :thinking: Post Windows reset that you attempted.

  1. If you’ve tried the regular method of accessing the BIOS (From a powered off state, power on & immediately tab Esc repeatedly until the Startup Menu appears, then press F10), do you even see the Startup Menu?

  2. Will the laptop allow you to bypass the connection to the network & proceed in the process? Typically if no network is available (wired or wireless), W10 will allow a local account to be created either by Skip or erroring out after clicking Next with a made up email address. :wink::thinking:

If you decide to remove the HDD, there may be an HP Support YT video to assist.

I have not seen the startup screen and have not yet removed the drive. I can bypass connecting to the Internet, but still cannot enter text the next time it is necessary. I am frustrated trying to get to setup and will look into removing the drive. I don’t know much about laptops but I think this will be a nice computer if I can get Linux on it. Thank you both for the help and I will post the results of removing the hard drive as soon as possible.

1 Like

As a last effort reformat drive c.

Then turn it off and back up.

Bios should open.

Good luck.

After seeing the videos on opening the case, I have hesitated. I need one of those plastic prying tools.

I tried to reset Windows and I’m stuck in reset mode because the keyboard stops working at certain points. I plan to attach a USB keyboard and try to reset again. I will also try to find a way to format the drive from reset mode.


I was able to install Linux Mint 20 on the laptop. I got into the bios by using a USB keyboard. When I first started working with with the computer, I know at least some of the function keys worked on the built in keyboard. Now, with Linux, none of the laptop’s keys work as far as I can determine.

I have found methods to reactivate a failed keyboard on a HP Laptop that is running Windows. One of the methods is to reload a keyboard driver. I have yet to find similar information for Linux.

Years ago I used Ndiswrapper to run a wireless network card on Linux with a Windows driver. Do you think this sort of thing can work for keyboards?

I knew you would figure it out sooner or later if you kept trying. Great job.

I still don’t have the built in keyboard working. It would not work with Linux so I reinstalled Windows 10. I tried deleting the keyboard drives and reinstalling. No luck. I ran the HP diagnostics tests and the keyboard passed. Will not create text on the screen by passed. Go figure.

I’ll keep trying. I will post here if I can get it to work with Windows, just in case someone is interested.

Could it be as simple as an either/or switch being flipped when the bios logic latches up to the USB keyboard? Is there a way to disable the USB keyboard while using it for the input and still be able to reactivate it?

Maybe unplug the USB keyboard with power on and reboot it with it still unplugged?

I noticed today that there is a CMOS error if I unplug the laptop (battery is no good), plug back in and turn on the computer. Could a dead CMOS battery be causing this? It does not happen when I reboot keeping the laptop plugged in. Could a CMOS error be causing the keyboard not to work? When I gain courage, I will try to change out the CMOS battery.

I’m by no means a laptop expert. But plain ole country-boy logic tells me that if the CMOS battery is dead and you kill power to the computer then any changes to the BIOS won’t be saved. The BIOS would more than likely then default to factory settings.